Enhancing NAS experience - The Community Package Hub is all about quality software, made for your Synology NAS. Collected from all over the world, reviewed and compliant to official requirements. Delivering thousands of packages to users every month ... become one of them today.

App details

package icon autorun
Developer: Jan Reidemeister
Version: 1.7 Firmware: 6.0-7321 and onward
Last update: 12/04/2016 Size: 40.96 Kb
Architecture: all
required packages: none
Description:
Execute scripts when connecting external drives (USB / eSATA).
Changelog:
1.7
- changed: compatibility with DSM 6.0
- changed: configuration moved to setup, just un- and reinstall if you want to change something
- fixed: eject does not properly work sometimes
- removed: all GUI, this includes the local backup scripts
(sorry, but I'm tired of the constant changes by Synology)
- note: for DSM 5.x use the version 1.6, which can be found
at http://www.synology-forum.de/showthread.html?53183-autorun
1.6
- changed: compatibility with DSM 5.1
1.5
- changed: configurable wait times before starting the script
1.4
!!! YOU HAVE TO RECREATE THE SCRIPTS FOR THE LOCAL BACKUP!!!
- changed: requires DSM 5.0+
- changed: include Perl package as requirement
- changed: local backup - adjustments for changes in DSM 5.0
- note: for DSM 4.3 and below use the version 1.3, which can be found
at http://www.synology-forum.de/showthread.html?53183-autorun
1.3
- changed: allow access to settings by any user in the admin group (code [c] dakkar)
- changed: link to restore encrypted backup added to main page
- fixed: unable to create backup-script when multiple drives attached (on some browsers)
1.2
- new: show warning for required Perl package
1.1
- new: report space left on the device in the log
- new: optional DSM notification when finished
- new: mount encrypted backup for restore - option for file name encryption added
- changed: adjusted notes for file name encryption
- fixed: script not executed when name changed
1.0
- new: local backup - option for file name encryption added
- changed: local backup - name must be entered manually (Synology changes that too often)
- changed: local backup - 10s sleep added to give the drive some time to be properly mounted
0.9
- new: now supports update
- changed: requires DSM 3.2
0.8
- fixed: don't log passwords
0.7
- new: local backup - option for encryption added
0.6
- changed: requires DSM 3.1
- fixed: local backup - wait till backup is finished
0.5
- fixed: incorrect handling of DS restarts
0.4
- new: create scripts for the local backup
0.3
- new: settings page in DSM added
0.2
- new: beep at start and finish
- new: use DS led for status
0.1
- intial test

 Comments (14)
Page  1  2 
  1. Willy De Wilde wrote on Jan 09, 2017 at 11:57 AM

    The autorun package, interfere with the HDD's hibernation.

    Disks come out of hibernation every 15 minutes.

    Willy

    Reply

  2. Andy wrote on Apr 01, 2016 at 10:03 AM

    As it is not working anymore with DSM 6.x, is it planned to update autorun?
    Or is there an alternative?

    Reply

  3. Tom wrote on Mar 31, 2016 at 11:10 AM

    Hi!
    I need help for this package...
    I just want to creat a scripts to copy files from USB-key, to internal HDD in Synology...
    How can I programm it to work, please... for exemple:
    copy from USB:\Folder1\File5.doc to HDD:\public\File5.doc
    copy from USB:\Folder3\File8.doc to HDD:\public\File8.doc
    copy from USB:\Folder3\File9.doc to HDD:\public\File9.doc
    and eject USB at the end...

    Thank you for your help,

    Reply

    1. Gabriel wrote on Mar 24, 2016 at 08:26 PM

      Still valid for DSM 6.0-7321
      Seems there is no support for this anymore ... unfortune :(

      Reply

  4. kahi wrote on Nov 30, 2015 at 08:37 PM

    Sorry, the page you are looking for is not found.
    Beim Start des Paketes bei der DSM 6.0 Beta 1 ist nicht kompatibel.

    Reply

  5. Jan Mes wrote on Aug 23, 2015 at 12:25 AM

    L.S.
    Autorun is fantastic, but after the backup job and eject usb, next backup won't start.
    Script has been removed after job??
    Can your help, please??

    Regards,
    Jan Mes

    Reply

  6. Florian wrote on Jan 09, 2015 at 04:18 PM

    Danke für die schnelle Antwort.

    Reboot des NAS habe ich bereits versucht, gleicher Fehler.

    Allerdings hast Du mich mit der Nase auf die Lösung gestossen: Paketzentrum -> Einstellungen -> Allgemein: Vertrauensebene: Jeder Herausgeber.

    Vorher war nur "Synology Inc." aktiv, aber nur bei der manuellen Installation gab es die korrekte Fehlermeldung dazu.
    Tausend Dank!

    Reply

  7. Florian wrote on Jan 09, 2015 at 03:33 PM

    Hallo, ich möchte dieses Tool sehr gern nutzen. Auf einem DS414slim, Version 5.1-5021, Perl installiert, schlägt die Installation von Autorum 1.6 jedoch fehl (Fehlermeldung: "autorun" konnte nicht installiert werden). Nach Reboot derselbe Fehler. Ist dieses Problem bekannt?

    Reply

  8. Raphael Pertl wrote on Sep 17, 2014 at 11:01 PM

    Hi Jan, ich möchte Autorun in meinem Abschlussprojekt gerne benutzen (Ausbildung zum IT-Systemkaufmann) und würde dir da gerne ein paar Fragen stellen, evtl kannst du mir ja eine Mail zukommen lassen. Gruß

    Reply

  9. Ste wrote on Feb 21, 2014 at 12:25 PM

    Great package, however I have a question. I have several encrypted shares that I have included in the local backup job. I wish to backup these shares unencrypted to a USB drive. As these shares are mounted on the Diskstation DS213j, I thought that the backup would be unencrypted, however this is not the case.

    Is it possible for the Autorun script to backup unencrypted copies od mounted encrypted shares?

    Thanks,

    Reply

    1. Eierkopp wrote on Feb 01, 2015 at 10:19 AM

      If the whole disk holds the filesystem, its "disk", "partition" otherwise. Garmin devices e.g. often have an unpartitioned first and a partitioned second storage. I changed the 1.6 udev rule to ENV{ID_FS_USAGE}=="filesystem".

      Reply

  10. Fran wrote on Mar 24, 2013 at 01:14 PM

    Grats, autorun is a great idea, but don't work when I insert a SD Card on my DS213. I simply modify the hotplug script and change de DEVTYPE line to :

    if [ \( "$DEVTYPE" != "disk" \) -a \( "$DEVTYPE" != "partition" \) ]

    Seems that HOTPLUG DEVTYPE of an sd card is "partition" instead of "disk". I am not and expert in HOTPLUG but seems to work perfectly.

    Finally my Synology import and sort photos by date (using exiftool script) when I insert my camera SD Card.

    Reply

Page  1  2 





Allowed tags: <b><i><br>Add a new comment: